Ad
Log in to vote
0

How do I temporarily disable walking animations?

Asked by 3 years ago

I'm making a game where you can do dances and emotes, and I want some of them to keep themselves on, even after you start walking. When I start the emote it's fine, but when I walk, it turns off again. How do I disable the thing where all animations stop on player move? (I only want it to be temporary, so I can turn in back on when the emote ends)

0
I would remove the animate script, but it wont may be the best solution maumaumaumaumaumua 628 — 3y

1 answer

Log in to vote
0
Answered by 3 years ago
Edited 3 years ago

If you want custom Animations test the game, go into your character model, copy the local script called "Animate" Now, simply edit the script to your custom animations by putting the animation ID into it.

Put a script into ServerScriptService Copy the local Animate script Paste it into the New Script in ServerScriptService

game.Players.PlayerAdded:Connect(function(Player)
local NewAnimate = script.Animate:Clone()
local Character = Player.Character
Character:FindFirstChild("Animate"):Destroy()
NewAnimate.Parent = Character
end)

Now if you simply want to make it so there are no Animations at all

Insert a script into ServerScriptService and put this function in

game.Players.PlayerAdded:Connect(function(Player)
local Character = Player.Character
Character:FindFirstChild("Animate"):Destroy()
end)

For For temp do

character.Animate.Disabled = true
--to pause the animation
--and to enable the animations again
character.Animate.Disabled = false
0
But I don't want it to be on forever. I want the player to walk normally again when they turn off the emote... TheLittleLambCraft 0 — 3y
0
Oh, your doing a animation gui just do Character.Humanoid:LoadAnimation( LegoUnicornRoblox 37 — 3y
0
Oh, your doing a animation gui just do Character.Humanoid:LoadAnimation(script.Animation) it should play over the player's animation LegoUnicornRoblox 37 — 3y
Ad

Answer this question