Ad
Log in to vote
0

How do I disable Jumping on a Humanoid?

Asked by
hiccup111 231 Moderation Voter
7 years ago

I've looked through the Wiki, but I cannot find a method to disable jumping.

I've used messy methods like forcing the player in one position, but as I said, messy, and it makes other problems with the physics.

If you have any information on this, even just a reference, I'd most appreciate it.

Thanks.

1 answer

Log in to vote
3
Answered by
RedCombee 585 Moderation Voter
7 years ago

In just about every instance (if not all), there is an Event called "Changed." When any value or child the instance carries changes in any way, this will activate. To use this to your advantage, jumping will change the Humanoid, so you can use:

humanoid.Changed:connect(function()
humanoid.Jump = false
end)

Just in case the change to the humanoid was that the player jumped, it will set this to false to make sure that the player can't jump.

0
This would most likely be a LocalScript in StarterGui with all variables defined. Shawnyg 4251 — 7y
0
Cheers, I didn't think Changed would react fast enough. By other Creator's replies to my question, I got the feeling it was a setting. hiccup111 231 — 7y
0
In a localscript it does. I use it all the time. RedCombee 585 — 7y
Ad

Answer this question