New: Nitro Boost our Discord server and receive full donation perks here on the website! Join the Scripting Helpers Discord Server to learn more! You can also Support on Patreon as always.
Ad
Still have questions? Join our Discord server and get real time help.
Log in to vote
0

Why won't my newly created animation play for an actual player? [SOLVED]

Asked by 1 year ago
Edited 1 year ago

I am very very new to animating..but I'm currently trying my hand at it. This is kind of a two-parter, but only the second part is a necessity at this moment in time.

Part 1: As of right now, I have created an animation using both the character and a tool, exemplified here: https://gyazo.com/b5a98480f7b2d67e59773055a6354d87 (yes I know fairly primitive, but I'm new to animation) How it is set up in the dummy is there is a Motor6D with Part0 as the right hand and Part1 as the handle of the tool. There is no Motor6D in the tool. When I play the animation on a player model (not an actual player), only the arm moves, and not the tool. How would I make the tool move as well? As of right now I have only tried putting an identical Motor6D in the player model, to no avail.

Part 2: So I have my animation, and when I test it in a model of a player it plays. However, when I try it with an actual player, the animation doesn't play. Here's what I've written:

local player = game.Players.LocalPlayer
local character = player:WaitForChild("Character")
local anim = character:WaitForChild("Humanoid"):LoadAnimation(script.Parent.Animation)

script.Parent.Equipped:Connect(function()
anim:Play()
print("played")
end)

It always prints that it was played, but never actually plays it. What is going wrong?

Edit 1: After a little more fooling around I've found that the animation is playing, but it doesn't actually show it when the tool is equipped? I'm even more confused now.

Edit 2: Realized I forgot to set its priority. Whoops. Still need help with Part 1 if anyone knows how to get the handle to animate with the arm.

Edit 3: I Figured it out. I ended up setting the actual Handle's transparency to 1 and creating a clone of the handle within a model rather than a tool, where the Motor6D connects the right hand and this fake handle. It played perfectly after that.

I seem to be learning more and more as I experiment.

Answer this question