Ad
Still have questions? Join our Discord server and get real time help.
Log in to vote
0

bodyvelocity object refusing to work unless moved a little in the studio?

Asked by 2 months ago
Edited by TheeDeathCaster 2 months ago

I ran into a problem applying ReplicatedFocus to a part inside a model.

replicatedfocus script:

wait(5)

local char = script.Parent

local plr = game.Players:FindFirstChild(char.Name)

local targetname = char.Name.."2"





local ship = game.Workspace:WaitForChild(targetname)



plr.ReplicationFocus = ship.MainBase.MasterCore

there are two bodyvelocity objects inside the same object replicated focus is applying itself to. both bodyvelocity objects work when this script is not ran, but If I run this script only one of the bodyvelocitys work. the other will only start moving if I pick the model up in the studio and move it a little. why is this happening and how can I fix it?

0
I put the code in a code block. TheeDeathCaster 2208 — 2mo
0
Is it welded to the floor? Picking it up could be breaking some joints somewhere. fredfishy 790 — 2mo
0
but thats the wierd part it cant be welded because another bodyvelocity and an agularvelocity can still move it, the only difference between the one that does not work and the one that does is that the broken one's velocity is set to *100 mantorok4866 41 — 2mo

Answer this question