Ad
Still have questions? Join our Discord server and get real time help.
Log in to vote
2

How can i stop jump animation from canceling my animation?

Asked by
KOK_E 12
5 months ago

This question has been solved by the original poster.

The problem i am having is i am making animation tools but when i jump it cancels the animation and if i press it while jumping it doesn't really work... this is the script

local player = game.Players.LocalPlayer
local mouse = player:GetMouse()

function keyD(key)
    local key = key:lower()
    local hotkey = script.Hotkey.Value
    if key == hotkey then

local animation = Instance.new("Animation")
        animation.AnimationId = "rbxassetid://2737702733"
local animloader = player.Character.Humanoid:LoadAnimation(animation)
        animloader:Play()
    end
end

mouse.KeyDown:connect(keyD)

If someone could edit it i would be thank full.

1
Use :Connect, this will not fix it yet help in the near future. WideSteal321 445 — 5mo
0
Make the priority of your animation higher than the jumping one or don't load the jumping one at all gullet 403 — 5mo
0
Already found solution thanks to kingdom5 KOK_E 12 — 5mo

1 answer

Log in to vote
0
Answered by 2 months ago

Import the animation into your animation editor and change the "Priority" setting to something higher than your other animation's priority setting. You can find the priority setting under the "edit" tab on the animation window.

Ad

Answer this question