01 | Door = game.Workspace.DoorPart |
02 |
03 | function onTouch(DoorPart) |
04 | Door.Transparency = 0.5 |
05 | Door.CanCollide = false |
06 | wait( 5 ) |
07 | Door.Transparency = 0 |
08 | Door.CanCollide = true |
09 | end |
10 |
11 | script.Parent.Touched:connect(onTouch) |
Just checking. :3
Yes. "Part" is a common name though, you should probably change it to remove the chance of confusion.