Scripting Helpers is winding down operations and is now read-only. More info→
Log in to vote

math.random(0.5, 1) only returning 0 and 1? [SOLVED]

Asked by 1 year ago
Edited by T3_MasterGamer 1 year ago

So I have a math.random variable and it should print values between 0.5, 0.6, etc. but it only prints 0 and 1. Here's my code:

local size = math.random(0.5, 1) 

Edit: I figured it out. So apparently, math.random rounds numbers. So I just did math.random(5, 10) / 10, and that worked.

1 answer

Log in to vote
Answered by 1 year ago

math.random only returns integers, if you want to have decimals then I suggest:

local random =
local random_integer = random:NextInteger(1, 10)
local random_number = random:NextNumber(1, 10)

print(random_integer) -- without decimals (6)
print(random_number) -- with decimals (6.1)
Not all the time. You see, math.random() only return decimals when it is not filled (meaning 0 and 1 are the parameters). It will only return integers if the difference between the two parameters are more than one. T3_MasterGamer 2189 — 1y
What do you mean by that? xXLegendGamerz16Xx 231 — 1y

Answer this question