Ad
Log in to vote
0

[SOLVED] GetUserThumbnailAsync appears on ScreenGui, but not SurfaceGui? [closed]

Asked by 18 days ago
Edited by imKirda 17 days ago

This question has been solved by the original poster.

Hello, I am trying to get my avatar's profile picture to appear on a part. The script I use works perfectly when used on a ScreenGui, but doesn't work at all one placed on a SurfaceGui, which is what I need to use in order to make it appear on a part. The image appears blank, and I am wondering what I am doing wrong. Thanks in advance!

local ImageLable = script.Parent

local Image = game.Players:GetUserThumbnailAsync(51195902, Enum.ThumbnailType.HeadShot, Enum.ThumbnailSize.Size420x420)

ImageLable.Image = Image

Locked by T3_MasterGamer, Puppynniko, and imKirda

This question has been locked to preserve its current state and prevent spam and unwanted comments and answers.

Why was this question closed?

1 answer

Log in to vote
0
Answered by 18 days ago

Nevermind, I figured it out. I just had to use "Script" instead of "LocalScript."

Ad