Scripting Helpers is winding down operations and is now read-only. More info→
Log in to vote

My script stopped working when using animation controller without any reasons, why?

Asked by 3 years ago

i have no idea how is it not working, im using an animation controller on a model.


local gasteridle
    local gasteropen
    local gasterfire
    local animctrl = gb.AnimationController
    local idleanim = gb:WaitForChild("Idle")
    local openanim = gb:WaitForChild("Open")
    local fireanim = gb:WaitForChild("Fire")
    gasteridle = animctrl:LoadAnimation(idleanim)
    gasteropen = animctrl:LoadAnimation(openanim)
    gasterfire = animctrl:LoadAnimation(fireanim)
What is "gb" ? XxGhostBoy_HDxX 38 — 3y
"gb" was a model with some part and animationcontroller in. 5412366La 12 — 3y

1 answer

Log in to vote
Answered by 3 years ago
Edited 3 years ago

I might try not defining the Animationcontroller with local. Try accessing it with gb.

Animations are weird, I know. They don't like local, they prefer the rig they were made with. That's a big one as well. Did you animate the animations with the rig you're trying to use? That may be why they won't play.

It's still not working, and no error was show up in output, this is weird 5412366La 12 — 3y
Hmm... try this. Don't define the animations themselves in the loadanimation. Just do gb.Something.Idle (Or something like that) TheB4dComputer 100 — 3y
I had trouble like this one time. I tried using an old animation from a regular r6 rig and all that it did was shake the torso. TheB4dComputer 100 — 3y
Still not working... 5412366La 12 — 3y
View all comments (2 more)
I placed it in another script and it suddenly works, but anyways thanks! 5412366La 12 — 3y
Oh yeah sometimes that works too TheB4dComputer 100 — 3y

Answer this question